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1. Abbreviations 

ROI: Region of interest 

LUT: Look-up table 

Stack: Data structure with a set of related images of the same size and bit depth. 

Slices: The images that make up a stack. 

Voxel: In stacks, a pixel (which represents the smallest 2D image data) becomes a voxel (volumetric 
pixel), i.e. an intensity value on a regular grid in a three dimensional space. 

2. Remarks 

This script was written for practical training purposes by the Center for Microscopy and Image Analysis, 
University of Zurich. Theory is kept to a minimum.  

The script should be used as a guideline for training. 

Highlighting styles used in this script: 

File names are set in green (e.g. Cell_Division_Pinhole_0_5AU_Nyquist_7386.lif) 

  
Practical steps are set in italic. Keyboard shortcurts here 
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3. Software: Imaris  

 

Bitplane Imaris is a commercial software package for the visualization, segmentation and analysis of 
multidimensional microscopy datasets.  

As confocal microscopes were first becoming commercially available, the founders of Bitplane, Marius 
Messerli, Karl-Hermann Fuchs, and Jürgen Holm, realized that there was no suitable way to visualize 
and analyze the images provided by this more modern equipment. While pursuing their research at 
the Institute for cell Biology at the ETH in Zurich the first productive version of Bitplane's core product, 
Imaris, was developed and released in 1993 (Adapted from Wikipedia). 

Today Imaris is still developed and sold by Bitplane: 

http://www.bitplane.com/ 

Besides the open source tools such as Fiji, Imaris is the most used software at the ZMB for exploring 
and analyzing microscopy images. The main reasons are the simplicity and the capability of easily 
visualizing data, segmentations and also quantifications in 3D or 4D. Especially for the 3D 
visualization there are as of now no open source tools with a similar performance and therefore Imaris 
and similar tools such as Thermo Scientific Amira or Arivis Vision4D are used in universities all around 
the globe. 

By Imaris XT, a software interphase for Python and Matlab, Imaris also allows you to write custom 
programs which can interact with the data and the visualizations.  

4. Opening Standard File Types 

In the background Imaris uses a version of the OME bioformats reader 
(https://www.openmicroscopy.org/bio-formats/). Therefore it should be able to open a very similar 
set of microscopy image file formats such as Fiji. You can open a file in Imaris using 

  
File>Open 

If you open multidimensional .tif files 
where each slice/channel/timepoint 
etc. is stored as a single file it might be 
necessary to instruct Imaris in how to 
interpret the filenames in a folder. This 
can be done in the file open dialog 
under “Settings” 

  



5. Explore Metadata and Calibrate Images 

You can explore the metadata of the opened file by using  

  
Edit>Image Properties 

 

Depending on your source file format (e.g. tif) the pixel/voxel size might not be calibrated. Be sure to 
check and correct the values here if needed. 

6. Resaving in the Native Imaris File Format 

In order to have the maximum visualization performance as well as software stability, we recommend 
resaving the data in the native Imaris file format (.ims) before doing any further image analysis. 

  
File>Save As 

1 channel 1 time 
point 

100 z slices 



  7 

 

 

7. Adjusting the Image Visualization  

In order to adjust LUTs of the different channels open 

  
Edit>Show Display Adjustment 

Click on “Advanced” to manually set the min/max values as well as the gamma. Play 
with these settings and see how the image representation changes.  

By clicking on the channel names you can change the names as well as the LUTs. 
Turning off and on channels by using the checkbox is also very useful for adjusting 
the values of one channel after another. 

 

 

 

 

 

Click into your image and see how you can change the view 
including zooming in and out using the mouse wheel. Make sure 
that your pointer selection on the right pane is on “Navigate”: 

Now put it on “Select” and try to manipulate the appearance of 
your scale bar. If you are not happy with the color of your scale bar 
or want to deactivate completely, you can go to 

 



  
File>Preferences>Display 

 

Here you can adjust the image representation to your liking. Keep in mind that these settings are global 
and will be kept when you next time start and use Imaris. 
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8. Slice Representations 

Explore the different slice image representations under the “Slice” icon such as the “Section” 
(Normally called ortho viewer). 

 

The “Slice” representation also allows you to do a maximum intensity projection of your dataset (Easy 
3D). 

9. Time Series 

If you open 2D or 3D time series either directly from a microscope format or by importing a .tif series 
with the proper “Settings” during opening, you should see a time bar which allows you to navigate the 
time dimension of your series 

 

If you imported your data without specifying the dimensionalities, and as an example a 2D time series 
is loaded as a single 3D volume you can also change this by 

  
Image Processing>Swap Time and Z 

 

  



 

10. Snapshots 

Go back to the “3D View” and explore the settings for the “Snapshot” 

  
File>Preferences>Snapshot 

 

Configure these settings according to your liking and make a few snapshot of your dataset by clicking 
on the “Snapshot” icon.  

 

Be sure to check where your snapshots are going to be saved. You can use this approach for making 
publication ready images using Imaris. 

11. Movie Animations 

If you have 3D or 4D datasets you might want to show those in a presentation as a rendered movie 
sequence. This definitely is one of the strengths of Imaris and can be done very easily.  

Activate “3D View” as well as “Animation” and you should see the “Key Frame Animation” pane. 

 

To make a movie sequence you can define “Key Frames”.  
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Keyframes in a movie animation are frames/views that define the start and the end of a smooth 
transition. Use navigation to find a perspective/view and zoom factor you like and “+ Add” a keyframe. 
Go to another position and add the next keyframe. Everything in between will be interpolated by the 
software.  

In order to achieve good animations it is recommended that you avoid changing the view too much in 
between two keyframes. Also the displacement distance of your transitions should be more or less 
homogenous between keyframes, otherwise your audience might become seasick. You can add as 
much keyframes as you like. Operations such as changing the brightness, show or hide certain channels, 
shown time points can also be included as transformations in between keyframes. 

You can review your animation using the play button 

 

If you have too many keyframes, the animation might start to stutter. In this case you might try 
increasing the number of frames. Please consider that more frames also means longer movies and 
more data to put into you presentation. Under “Settings” in the animation pane you can adjust the 
frame rate. Values above 25 are recommended in order to get smooth movies. The number of frames 
divided by the framerate gives you the playing time of your movie in seconds. 

You can press the red record button to render and save the movie 

 

Be sure to use a movie file format that is supported by your operating system and presentation 
software such as Microsoft PowerPoint (Test this before defending your PhD!). If you are done, close 
the “Animation” pane. 

  



12. 3D Segmentation and Surfaces 

Next we will try to make an intensity based 3D segmentation and 
visualization. In the “3D View” go to the “Scene – Properties” pane and click 
the blue Icon “Add new Surface”. 

 

 

 

 

Then a surface creation wizard starts. 

Section 1/6 

Select “Segment only a Region of Interest” and “Process entire Image 
finally”. This allows you to do your parametrization on sub-volumes of your 
dataset and therefore everything is much more fluid and responsive. If you 
then set everything up correctly, the whole dataset can be processed at the 
end using your defined parameters. 

Section 2/6 

Press next and Switch the “Pointer” between “Navigate” for adjusting the 
view and “Select” for adjusting the “Region of Interest” box (You can also 
switch between “Navigate” and “Select” by pressing the Escape button). If 

your image is very heterogeneous you can also place multiple “Region of Interest” Boxes for 
parametrization by pressing “Add”. Then press next 
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Section 3/6 

 

In step 3 you can select the channel you want to segment and also 
decide if you want to apply a feature smoothing as well as an adaptive 
thresholding with a local background subtraction. If you are unsure 
try with the default values and if you are not happy you can always go 
back. Also evaluate the effect off different settings (try to use extreme 
values, then the effect should become more obvious) 

 

 

 

 

Section 4/6 

In step 4 you can adjust the intensity threshold for 
segmentation. For the way the wizard in Imaris 
works it’s usually better to include a bit more of 
your intensity (Lower threshold) and then in the 
following steps to work with filters. If you have 
difficulties to interactively see your segmentation 
results, you can also toggle off and on the different 
channels in the “Display Adjustment” window.  

  



Section 5/6 

 

In step 5 you can classify/filter your surfaces using a combination of 
various filters. As an example, this can be useful to remove small dot 
like structures, which might not be of interest. Also this allows to use 
the intensity information of other channels and therefore as an 
example find structures which have an intensity in two different 
channels. 

 

 

 

 

Section 6/6 

Since you have now adjusted all parameters, you can apply the segmentation of your ROI to the whole 
dataset in step 6. This can take a bit of time. If you have a time series, the surface generation will be 
performed for all time points.  

 

 

When your segmentation is done, you can adjust the visualization of your surfaces, manually delete 
objects which are not of interest and explore and export (e.g. to excel or matlab) the statistics for each 
individual object or globally. 
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Something simple but very helpful to see patterns and trends in your data is the statistical coding of 
objects. Here you can assign a color according of one of the objects variables such as size or roundness.  

 

You can make as many surfaces as you want. The surface objects are different from your intensity data 
since they consist of a 3D mesh and not voxels. This allows for advanced rendering using a virtual light 
source. You can adjust the position and intensity of your virtual light by clicking on “Light Source 1” in 
the “Scene” pane. 

  



13. Literature and Further Information 

• The Imaris reference manual 

http://www.bitplane.com/download/manuals/ReferenceManual9_2_0.pdf 

• The Imaris learning center where you can find many nice examples of how the 

software can be used 

http://www.bitplane.com/learning 

• Community extensions for Imaris 

http://www.bitplane.com/download 

http://open.bitplane.com/  

• Two alternatives to Imaris 

https://www.arivis.com/de/imaging-science/arivis-vision4d 

https://www.thermofisher.com/ch/en/home/industrial/electron-

microscopy/electron-microscopy-instruments-workflow-solutions/3d-visualization-

analysis-software.html 

 

http://www.bitplane.com/download/manuals/ReferenceManual9_2_0.pdf
http://www.bitplane.com/learning
http://www.bitplane.com/download
http://open.bitplane.com/Default.aspx?tabid=237
https://www.arivis.com/de/imaging-science/arivis-vision4d
https://www.thermofisher.com/ch/en/home/industrial/electron-microscopy/electron-microscopy-instruments-workflow-solutions/3d-visualization-analysis-software.html
https://www.thermofisher.com/ch/en/home/industrial/electron-microscopy/electron-microscopy-instruments-workflow-solutions/3d-visualization-analysis-software.html
https://www.thermofisher.com/ch/en/home/industrial/electron-microscopy/electron-microscopy-instruments-workflow-solutions/3d-visualization-analysis-software.html
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